Teams Telefonie Gesprächsabbrüche nach 32 Sekunden

Im Augenblick brechen viele einige ausgehende Telefonate unter Teams nach genau 32 Sekunden ab.

Dieser „Effekt“ tritt bei vielen - aber (noch?) nicht allen Microsoft-Tenants auf.

Wir vermuten die Ursache bei Teams und arbeiten mit Hochdruck daran die Ursache abzuklären.

Eine Statusaktualisierung ist in ca. 30 Minuten geplant.

Wir haben die vermutliche Ursache identifiziert und arbeiten mit Hochdruck mit Microsoft und dem Provider an der Behebung.

Parallel prüfen wir Möglichkeiten für einen Workaround auf unserer Seite.

Betroffen sind nach unserer Statistik ca. 10-20% der ausgehenden Anrufe. Im Zweifelsfall also (leider) öfters probieren und den Gesprächspartner ggf. am Anfang (in den ersten 30 Sekunden) darauf hinweisen :frowning:

Nächster Status wieder in ca. 30 Minuten.

Leider haben sich sämtlich Workaround-Versuche auf unserer Seite „zerschlagen“.

Wir sind weiter daran, das zugrundeliegende Problem zu beheben (entsprechende Tickets sind eröffnet und in Bearbeitung).

Nächste Kommunikation spätestens Montag morgen.

Auch ohne eine Rückmeldung an den Tickets sieht das Verhalten im Moment besser aus und lässt sich nicht meehr reproduzieren.
Also vermute ich, dass entweder beim Provider oder bei Azure eine Änderung stattgefunden hat.

Wir beobachten weiter, ob das Problem erneut auftritt und geben Montag gegen 12:00h Rückmledung, ob wir es als „geschlossen“ betrachten oder ob es weiter auftritt.

Weitere Testreihen und das Feedback unserer Kunden zeigen, dass das Problem noch oder wieder auftritt und sich zwar in wenigen Fällen, aber doch wieder reproduzieren lässt.

Wir bleiben weiter dran.

Einige intensive nächtliche Debug-Sessions haben es uns nicht nur ermöglicht, den Fehler schneller zu reproduzieren, sondern auch eine Schuld „unserer“ Azure-Infrastruktur mit an Sicherheit grenzender Wahrscheinlichkeit auszuschliessen.

Dadurch konzentrierten wir uns auf potentielle „Fehl-Interpretationen“ beim Provider. Nach einigen internen Runden sind wir jetzt relativ sicher, die Änderung des Verhaltens auf Provider-Seite umgangen zu haben - 15 ausgehende Testanrufe in Folge waren stabil, während vorher ca. 1 von 3 oder 4 Anrufen abbrach.

Daher betrachten wir das Problem als gelöst - FALLS es bei Ihnen weiterhin auftreten sollte, melden Sie sich bitte über die üblichen Support-Kanäle oder hier am Forumseintrag.

Leider hat sich unsere Freude als verfrüht gezeigt.

Obwohl heute Nacht die Testcalls erfolgreich waren, melden uns Kunden das Verhalten wieder und wir können es auch im Monitoring sehen.

Wir sind weiter an der Problembehebung.

Seit ca. 12:45 haben wir einen zweiten Workaround geschaltet und bis jetzt (13:30) keine weiteren Vorkommnisse in den Logs/Monitoring gefunden.

Leider ist eine Nebenwirkung des Workarounds, dass die MoH (Music On Hold) nicht funktioniert.

Wir schreiben hier, wenn das Problem endgültig gelöst ist.

Seit Mittwoch ist das Problem endgültig gelöst und der Workaround „zurückgerollt“.

Damit sollte in den „üblichen Teams-Szenarien“ ( Music on Hold - Microsoft Teams | Microsoft Docs ) Music on Hold auch wieder für PSTN-Anrufe abgespielt werden.